Inobitec DICOM Viewer

15.6. Modules

In this section you can specify the settings for particular modules (Fig. 15.3).



To browse the detailed information about each module, select the module and click the Module info button. For some modules, special parameters are set. To do this, select the module from the Installed modules list and click the SETTINGS button.

15.6.1 Set Up Image Viewer Module

Select the Image Viewer module from the Installed modules and click the SETTINGS button. The Image viewer settings window contains four tabs with the following parameters:

  1. Image arrangement tab. The following parameters are set up:

    These parameters can be set for a specific modality. To add a modality, click the ADD button and enter the name of the modality in the dialog that appears. To change the settings for a previously added modality, select it in the Settings for modality drop-down list. To delete the selected modality click the REMOVE button.

  2. Tools tab. The following parameters are set up:

    • default tool (the one that activates when opening an image). Options:

      • no tool;

      • Adjust W/L;

      • Ruler;

      • Corner meter;

      • ROI rectangle tool;

      • ROI ellipse tool;

      • ROI polygon tool;

      • Sync by point;

    • default mode. Options:

      • no mode selected;

      • DSA mode;

    • request for confirmation before deleting all annotations and measurements;

    • enable/disable the warnings of non-bilinear interpolation;

    • show TSE values in annotations;

    • enable/disable default synchronization of series image scrolling;

    • enable/disable slices scaling and position synchronization for various projections.

  3. Controllers tab. Sets up the actions associated with mouse actions.

  4. W/L settings tab. Sets up the default W/L values. If a value is not specified, the default is 0.

  5. W/L settings tab. The following parameters are set up:

    • option Use recommended W/L for Series can be checked/unchecked;

    • default W/L for DSA mode can be activated/deactivated;

15.6.2 Set Up Study List Module

Select the StudyList module from Installed modules and click the Settings button. The following parameters are set up in the Study list config window:

15.6.3 Set Up 3D Reconstruction Module

Select the 3D Reconstruction module from Installed modules and click the Settings button. The window contains two tabs with the following parameters:

  1. Render tab.

    By default, the imaging device is selected by the program automatically and is shown on the drop-down list as the Auto option. The cache memory limits that can be changed are displayed for this device. For each device on the drop-down list, the amount of memory available for caching is displayed.

    The fields for setting cache memory limits are provided with a restore recommended value button PIC . The restore recommended value button is displayed when the limit value provided is different from the recommended value. To restore the recommended value of a cache memory limit, click the PIC button in the respective field.

    PIC You cannot customize the cache memory limits for the CPU (software). The cache memory limits for this device are calculated on the basis of the values provided in the General tab (see Section 15.1).
  2. Segmentation tab. The following parameters are set up:

    • sets the default structure opacity;

    • option Invert edit mask on MPR can be checked/unchecked;

  3. Project tab.

    • Sets up the function of saving projects:

      • Enables/disables the Save DICOM data of series option;

      • Enables/disables the Enable autosaving option;

      • Sets the autosave frequency on the Timeout dropdown list.

    • Selects the mode in which the saved project is to be opened: 3D, MPR or Both.

  4. Reconstruction tab.

    • option Warn about varied slices distance can be checked/unchecked;

    • sets up reconstruction by series with varying distances between slices. Options:

      • Non uniform slice interpolation;

      • Max uniform distance slice range.

  5. UI tab. The following parameters are set up:

    • Saving MPR view sizes. To change this parameter, checks/unchecks option Save MPR view sizes. By default, it is unchecked;

    • MPR plane line thickness, including Screw Installation window.

    • MPR plane line colors, including Screw Installation window.

    • Disabling the display of the standard space orientation panel in the Volume reconstruction and 3D view windows of the MPR reconstruction tab. By default, it is enabled. To disable the display of the panel, untick the Show a panel of standard projections in a 3D view box. The changed panel display settings are not applied to the tabs and windows that had been opened before the changes were introduced.

    • Request for confirmation before deleting all measurements.

  6. 3D controllers tab. Sets up the actions associated with mouse actions in the Volume Reconstruction window.

  7. MPR controllers tab. Sets up the actions associated with mouse actions in the MPR, Planning of Pedicle Screw Installation and Vessel Analysis windows.

15.6.4 Set Up Vessel Analysis Module

Select the Vessel analysis module from Modules and click the Settings button. The window contains tab with the following parameters:

  1. UI tab. The following parameters are set up:

    • Enabling saving the window size in the Vessel analysis tab. By default, it is disabled.

    • Disabling the display of the standard space orientation panel in the 3D view window of the Vessel analysis and Coronary arteries analysis tab.By default, it is enabled. To disable the display of the panel, untick the Show a panel of standard projections in a 3D view box. The changed panel display settings are not applied to the tabs and windows that had been opened before the changes were introduced.

    • Disabling the option Request a non-enhanced series to remove bones on window opening. By default, it is enabled.

15.6.5 Set Up Network Support Module

Select the Network support module from Installed modules and click the SETTINGS button. You can specify the maximum count of connections to a PACS Server.

15.6.6 Set Up Local Storage Module

Select the Data storage module from Installed modules and click the SETTINGS button. The window contains one tab with the following parameters:

  1. the Automatic local storage cleaning option can be checked/unchecked;

  2. cleaning interval can be set.

15.6.7 Set Up «DICOM CD/DVD Creator»

Select the DICOM CD/DVD creator module from the Installed modules and click the SETTINGS button. You can specify the following parameters:

15.6.8 Set Up PET Analysis Module

Select the PET Analysis module from Installed modules and click the SETTINGS button. You can specify the following parameters: