Инобитек DICOM-Просмотрщик

6.11. Сохранение и открытие проектов сегментации и DTI

____________________________________________________________________________________________

Функциональность доступна в дополнительном модуле, который активируется в редакции "Pro" за отдельную плату
____________________________________________________________________________________________

DICOM-Просмотрщик позволяет сохранять проекты сегментации и DTI в файл. В одном проекте могут содержаться структуры и данные DTI для разных серий, a также исходные DICOM-данные. Если проект сохранён без исходных DICOM-данных, то открыть его без предварительной загрузки соответствующей серии (серий) невозможно.

Кнопки "Сохранить проект" PIC и "Открыть проект" PIC сгруппированы в одну кнопку управления проектами. В зависимости от того, какое действие выполнялось последним, иконка кнопки имеет вид PIC или PIC . При нажатии на левую часть кнопки выполняется последнее действие. Чтобы выбрать другое действие, нажмите на стрелку в правой части кнопки управления проектами (выделено красной рамкой на рис. 6.29).



6.11.1 Сохранение проекта

Чтобы включить/отключить сохранение исходных DICOM-данных, выберите главное меню Настройки->Параметры...->Модули->3D-реконструкция, вкладка "Проект"
(рис.
6.30) и установите/снимите флаг "Сохранить DICOM-данные серии". По умолчанию сохранение данных включено.

Кнопка "По умолчанию" восстанавливает флаг "Сохранять DICOM-данные серии".

Нажмите "OK", чтобы применить изменения, или "Отмена" для отмены.



Чтобы сохранить проект, нажмите на стрелку в правой части кнопки управления проектами (рис. 6.29), выберите "Сохранить проект" PIC , в открывшемся диалоге введите путь к файлу и имя файла и нажмите "ОК" для сохранения или "Отмена" для отмены действия. Файл проекта имеет расширение (spj).

В проекте сохраняются данные об ориентации и проекции модели. Ориентация и проекция модели восстанавливаются при открытии проекта.

Если проект открыт во вкладке мультипланарной реконструкции, то восстанавливаются:

  • поворот и расположение секущих плоскостей;

  • позиция модели;

  • масштаб модели.

Поворот среза модели во вкладке мультипланаорной реконструкции не восстанавливается.

Если проект открыт во вкладке объёмной реконструкции или в окне "3D представление" вкладки "МПР", то восстанавливается:

  • поворот модели;

  • позиция модели;

  • масштаб модели;

  • тип проекции.

Если проект был сохранён во вкладке мультипланарной реконструкции, а открыт во вкладке объёмной реконструкции, то восстанавливаются параметры, применимые только к окну "3D представление".

В проекте для каждого слоя сохраняются маркеры — "Точка", "Маркерная линия" и "Полигональная маркерная линия". Измерения длин и углов, выполненные с помощью полигональных маркерных линий, сохраняются в файле проекта. Работа с маркерами описана в разделе 5.9.

6.11.2 Открытие проекта с исходными DICOM-данными

При открытии проекта DICOM-Просмотрщик отображает его во вкладке "Объёмная реконструкция" либо "Мультипланарная реконструкция". Чтобы настроить вкладку по умолчанию, выберите главное меню Настройки->Параметры...->Модули->3D-реконструкция, вкладка "Проект" (рис. 6.30) и выберите режим открытия проекта "3D" или "МПР". По умолчанию выбран параметр "3D".

Кнопка "По умолчанию" восстанавливает флаг "Сохранять DICOM-данные серии".

Нажмите "OK", чтобы применить изменения, или "Отмена" для отмены.

В проекте сохраняются данные об ориентации и проекции модели. Ориентация и проекции модели восстанавливаются при открытии проекта. Подробнее см. в разделе 6.11.1.

Открыть проект, содержащий исходные DICOM-данные, во вкладке по умолчанию можно тремя способами:

  1. Выберите пункт "Открыть проект..." в меню "Файл". В открывшемся окне выберите файл проекта, нажмите "Открыть" для открытия проекта или "Отмена" для отмены действия.

  2. Дважды щёлкните левой кнопкой мыши по файлу проекта в окне проводника. Функция доступна по умолчанию только на ОС Windows. В macOS и Linux настройте системными средствами ассоциацию между форматом (spj) и программой DICOM-Просмотрщика.

  3. Перетащите файл проекта на ярлык DICOM-Просмотрщика (доступно только на ОС Windows и macOS). При перетаскивании нескольких файлов проектов на ярлык DICOM-Просмотрщика, каждый файл открывается в отдельной вкладке.

Чтобы открыть часть проекта и указать вкладку, в которой необходимо его открыть, выполните следующие действия:

  1. Выберите пункт "Открыть проект как..." в меню "Файл". В открывшемся окне выберите файл проекта, нажмите "Открыть" для открытия проекта или "Отмена" для отмены действия. Открывается диалоговое окно, изображённое на рис. 6.31.

  2. Выберите вкладку, в которой необходимо открыть проект (Режим "3D" или "МПР"). Выбранная вкладка будет установлена по умолчанию.

  3. Отметьте флагами серии в блоке "Список серий", для которых необходимо отобразить данные. По умолчанию флагами отмечены все серии проекта. Чтобы серия не открывалась в проекте, снимите с неё флаг.

  4. Порядок отображения серий важен для работы с проектом. По умолчанию серии отображаются в списке в том же порядке, что при сохранении проекта сегментации. Чтобы изменить порядок отображения серий, выделите серию в блоке "Список серий". Кнопками "Переместить вверх" PIC и "Переместить вниз" PIC (обозначены красной рамкой на рис. 6.31) переместите выбранную серию вверх или вниз.

  5. Нажмите "ОК" для открытия проекта или "Отмена" для отмены действия.

  6. Первая серия в блоке "Список серий" принимается за базовую.

    • Базовая серия во вкладке "МПР-реконструкция" отображается в виде фонового слоя за остальными слоями. Фоновый слой зафиксирован. Центр фонового слоя совпадает с центром окна. Слои могут перемещаться относительно фонового слоя и друг друга инструментами на панели совмещения слоёв. Совмещение слоёв описано в разделе 4.3.

    • Проект, открытый в окне объёмной реконструкции, отображается в виде объёмных моделей, построенных независимо друг от друга. Базовая серия проекта отображается в виде объёмной модели, зафиксированной в начале координат, совмещённым с центром модели. Модели из других серий располагаются в пространстве относительно модели, построенной из первого слоя. Изменение порядка слоёв при открытии проекта не влияет на взаимное расположение моделей.



Если проект не содержит исходных DICOM-данных, при попытке его открыть возникает ошибка "Не удаётся найти данные DICOM в файле проекта". Открытие проектов без DICOM-данных описано в разделе 6.11.3

6.11.3 Открытие проекта без исходных DICOM-данных

Открыть проект, не содержащий исходных DICOM-данных, можно только предварительно открыв исходные данные во вкладке "Объёмная реконструкция" или "Мультипланарная реконструкция".

Чтобы открыть проект, не содержащий исходные данные, выполните следующие действия:

  1. Откройте во вкладке "Объёмная реконструкция" либо "Мультипланарная реконструкция" исходную серию (серии), для которых был сохранен проект.

  2. Откройте панель сегментированных структур, нажав на кнопку PIC .

  3. Нажмите на стрелку в правой части кнопки управления проектами и выберите "Открыть проект" PIC . В открывшемся окне выберите файл, содержащий проект для данной серии, нажмите "Открыть" для открытия проекта или "Отмена" для отмены действия.

В проекте сохраняются данные об ориентации и проекции модели. Ориентация и проекции модели восстанавливаются при открытии проекта. Подробнее см. в разделе 6.11.1.

Содержащиеся в проекте сегментированные структуры и данные DTI для данной серии добавляются на панель сегментированных структур. При повторном открытии проекта данные добавляются снова, не заменяя ранее добавленные. При редактировании структур на панели сегментации содержимое файла не изменяется. Если файл проекта содержит данные для нескольких серий, то загружены будут только те, которые соответствуют серии, открытой в данный момент во вкладках объёмной или мультипланарной реконструкции.